Go PHP 5 : Adaptando aplicações ao PHP 5

O PHP 4 cumpriu o seu papel junto a comunidade de desenvolvimento WEB, porem o PHP 5 já está ai a algum tempo, e a transição tem sido lenta. Com as novidades extraordinárias da versão 5, as aplicações anteriores tornaram-se obsoletas e grande parte delas, precisa se adaptar às “novidades”. Como a maioria dos projetos ainda está em PHP 4, normalmente os Hosts suportam apenas essa versão. Sem aplicações novas, nem Hosts com suporte a PHP 5 estamos em um circulo vicioso.
Para mudar isso um grupo de desenvolvedores lançou a campanha Go PHP 5, entre projetos e Hosts para tornarem-se compatíveis ao menos com a versão 5.2.0 até 5 de fevereiro de 2008.
O Go PHP 5 veio em boa hora porque o site oficial do PHP divulgou que apartir de 31 de dezembro de 2007 o PHP 4 não será mais suportado e serão feitas atualizações de segurança no core incompatíveis com a antiga versão.
Entre os projetos participantes estão PERL, phpPgAdmin, phpMyAdmin, PHPUnit, Drupal e o Sympony.
Como já havia comentado, pouca gente usa a POO em PHP e vou ajudar o Go PHP 5 divulgando formas de se usar as funcionalidades do PHP 5 em POO. Aguardem por novidades no blog.

2 comentários sobre “Go PHP 5 : Adaptando aplicações ao PHP 5

  1. Valeu fabiano, Falha minha.Você acha que esse Go PHP5 vai realmente dar certo por aqui? É meio difícil achar host php5 por essas bandas?

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s