Como instalar Rails no Ubuntu

Como ter um ambiente de desenvolvimento para Ruby on Rails no Ubuntu? Simples:

Primeirio temos que instalar o interpretador Ruby:

sudo apt-get install ruby rubygems irb ri rdoc ruby1.8-dev build-essential

depois os gems do Rails:

sudo gem install rake activesupport activerecord actionpack actionmailer activeresource rails

Assim teremos a versão mais atual do Rails.

Mas ainda falta registrar os gems nas variáveis de ambiente.

sudo gedit /etc/bash.bashrc

inclua a linha


#Rails
export PATH=$PATH:/var/lib/gems/1.8/bin

Agora é só testar

rails -v

🙂

Um comentário sobre “Como instalar Rails no Ubuntu

  1. Muito bom o artigo, parabéns pela ajuda…e abusando da boa vontade … (Preciso programar em Rails e não consigo nem instalar o ruby direito… ;-\)Após instalar o ruby 1.8.7 patch level 22 no ubuntu 8.04 hardyme occoreu o seguinte erro ao instalar a gem 1.2:xyz@xyz: /usr/local/src/rubygems-1.2.0$ sudo ruby setup.rb/lib/rubygems/spec_fetcher.rb:1:in `require’: no such file to load –zlib (LoadError)Primeiro instalei compilando os fontes:sudo apt-get install gcc g++ build-essentialcd /usr/srcsudo wget ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p22.tar.bz2sudo tar -jxvf ruby-1.8.7-p22.tar.bz2cd /ruby-1.8.7-p22sudo ./configuresudo makesudo make installruby -vruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux]) …okcd /usr/srcsudo wget http://rubyforge.org/frs/download.php/38646/rubygems-1.2.0.tgzsudo tar -zxvf rubygems-1.2.0.tgzcd rubygems-1.2.0sudo ruby setup.rberro…Depois eu tentei instalar o ruby de diversas formas diferentes incluindo as bibliotecas libz também.sudo apt-get install ruby rdoc ri irb libyaml-ruby libzlib-ruby ri ruby1.8-devsudo apt-get install ruby rubygems irb ri rdoc ruby1.8-dev build-essentialsudo apt-get install -y ruby1.8 ri1.8 rdoc1.8 rake irb1.8A cada nova instalação do ruby eu tentei instalar o rubygems 1.2 direto dos fontes como fiz na primeira vez, então o mesmo erro ocorreu, daí refiz o processo de remoção e instalação dos pacotes novamente.Depois descobri que o meu Ruby está “desinstalável”….rsssApós tentar os comandos abaixo…sudo apt-get remove ruby libruby libruby1.8 ruby1.8 irb rdoc risudo aptitude remove rubysudo dpkg –list | grep ruby, dpkg -rpelo Synaptic também removi as bibliotecas relacionadas .. e nadaapós um ruby -vruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux]) !!!!Como eu posso resolver isto? Já enfrentou este problema?se vc puder me ajudar fico muito grato!Ruby sem gems não dá…rsssss Quero programar Rails no Ubuntu!Dizem que é fácil, mas como diria o capitão nascimento “quem disse que a vida é fácil” Obrigado pela atenção.Att.Bruno (brunormoura@gmail.com)

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s